La version gratuite de Yoast SEO mise à jour vers la version 19.10 et la version premium vers la 19.5, introduisant de nombreux changements importants.

Voici ce que vous devez savoir sur ces versions si vous envisagez de mettre à jour ou non.

Compatibilité WooCommerce 7.1

Les versions gratuite et premium profitent aux utilisateurs qui exécutent la version 7.1 de WooCommerce récemment publiée.

WooCommerce 7.1 est une version énorme et parmi les améliorations figure une modification de la base de données appelée High Performance Order Storage (HPOS).

Le stockage de commandes haute performance apporte des modifications à la base de données, de sorte que l’activation de cette nouvelle fonctionnalité est facultative pour le moment afin de laisser le temps aux développeurs de plugins de rattraper la nouvelle fonctionnalité.

Un explicateur de WooCommerce a noté :

« Après la première version de production, la fonctionnalité HPOS continuera d’être opt-in et nous aiderons les développeurs à rendre leurs plugins compatibles avec HPOS, à surveiller de près le nombre d’extensions compatibles et le nombre de magasins testant activement la fonctionnalité. »

Yoast 19.10/19.5 Premium sont tous deux compatibles avec la nouvelle fonctionnalité WooCommerce HPOS. Cela signifie que si l’activation de HPOS entraîne un plantage du site Web, il est prudent d’exclure Yoast SEO comme coupable.

Les utilisateurs du module complémentaire WooCommerce SEO pour Yoast bénéficieront également d’une mise à jour des données structurées qui les rend éligibles aux nouvelles améliorations de la recherche dans Google.

Yoast 19.10 corrige un bogue d’erreur fatale

Le plugin Yoast SEO mis à jour propose un correctif pour un bogue pouvant entraîner des plantages du site Web.

Le journal des modifications Yoast SEO attribue le problème à d’autres plugins (sans nom):

« Corrige un bogue où une erreur fatale serait générée dans l’éditeur classique en combinaison avec certains plugins qui abusent des crochets de métabox. »

Un exemple de métabox est un champ personnalisé qui permet aux utilisateurs d’ajouter du contenu supplémentaire qui ne se trouve pas dans le contenu principal.

Corrige deux bogues liés à Elementor

Le premier correctif lié à Elementor répare un problème qui affectait la capacité de sauvegarder les métadonnées Yoast SEO (dans certaines circonstances), ce qui est un gros problème.

Le journal des modifications indique :

« Corrige un bogue où les métadonnées de publication liées à Yoast SEO ne seraient pas enregistrées si un utilisateur sans la capacité manage_options enregistrait une publication dans Elementor. »

Le deuxième correctif de Yoast est lié au précédent en ce sens qu’il découle du même « capacité manage_options » problème.

Le changelog explique :

« Corrige un bogue où les utilisateurs avec une authentification d’accès de base à l’échelle du site seraient invités à insérer leurs informations d’identification lors de l’enregistrement d’un message dans Elementor s’ils n’avaient pas la capacité manage_options. »

Compatibilité WordPress 6.1 et divers

La version 19.10 a rendu obsolète plus d’une douzaine de crochets utilisés pour ajouter du contenu personnalisé aux pages de paramètres Yoast SEO.

Enfin, Yoast SEO offre une compatibilité totale avec le nom de code WordPress 6.1 qui vient de sortir, Misha.

Devriez-vous mettre à jour vers la dernière version de Yoast SEO ?

Certaines personnes préfèrent naturellement attendre avant de mettre à jour un plugin en cas d’erreur majeure et ce n’est pas une mauvaise stratégie.

Yoast SEO est utilisé par plus de cinq millions d’éditeurs de sites Web. Le plugin mis à jour a été publié hier et il n’y a aucun rapport dans le forum de support Yoast SEO qui indique qu’il y a des problèmes répandus avec cette mise à jour.

En fait, il n’y a actuellement que des problèmes aléatoires qui ont parfois plus à voir avec d’autres plugins et thèmes.

Aucun problème n’indique un modèle de problèmes liés à cette mise à jour.

Envisager la mise à jour vers la dernière version de Yoast SEO est une bonne idée, en particulier pour ceux qui utilisent WooCommerce ou Elementor, mais sans s’y limiter.

Yoast SEO 19.10/19.5 Premium sont tous deux compatibles avec la dernière version de WordPress, ce qui en soi fait de la mise à jour une option souhaitable et constitue une bonne pratique pour utiliser la dernière version de tous les plugins et thèmes, car cela permet d’éviter les problèmes d’incompatibilité.

Image sélectionnée par Shutterstock/Luis Molinero

LAISSER UN COMMENTAIRE

S'il vous plaît entrez votre commentaire!
S'il vous plaît entrez votre nom ici